Apacheの脆弱性情報(Low: CVE-2018-11763)



こちらでは主にOSSの脆弱性を取り上げていきます。09/25/2018にApacheの脆弱性情報(Low: CVE-2018-11763)が公開されています。SeverityはLowですが、広く使われているApacheのため、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

こちらでは主にOSSの脆弱性を取り上げていきます。09/25/2018にApacheの脆弱性情報(Low: CVE-2018-11763)が公開されています。SeverityはLowですが、広く使われているApacheのため、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

Low (CVE-2018-11763)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11763
    • 細工されたSETTINGSフレームを用いたHTTP/2接続によるDoS
    • 重要度 - Low
    • 影響するバージョン - httpd 2.4.34, 2.4.33, 2.4.30, 2.4.29, 2.4.28, 2.4.27, 2.4.26, 2.4.25, 2.4.23, 2.4.20, 2.4.18
    • HTTP/2接続で最大サイズのSETTINGSフレームを連続して送り続けることにより、タイムアウトせずにbusy状態が続くことになり、サーバへのDoSになります。これはh2プロトコルを有効にしている場合のみに発生します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteやKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品を使うとサービス断の時間を最小限にすることが出来ます。


セミナー情報 1

2018年10月22日から10月25日のCSS(Computer Security Symposium)2018で、「OSSセキュリティ技術ワークショップ(OWS) 2018特別セッション」 と題しまして、OSSセキュリティ技術の会後援で特別セッションを開催します。

https://www.iwsec.org/ows/2018/index.htmlにプログラム内容と一般論文申し込みの詳細を載せていきますので、是非御確認下さい(ページは更新中です)。


セミナー情報 2

2018年10月04日に、「OSSの長期利用とメンテナンス 」と題しまして、やまね氏によるセミナーが開催されます。

https://sios.connpass.com/event/100751/にプログラム内容と申し込みページがありますので、是非御確認下さい。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Pythonの脆弱性情報(CVE-2018-14647)

次へ

広いバージョンのLinux Kernelに脆弱性(Important: CVE-2018-14634)(Mutagen Astronomy)