Apache HTTP Serverの脆弱性情報(Moderate: CVE-2021-44224, High: CVE-2021-44790)と新バージョン(2.4.52)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/20/2021にApache HTTP Serverの脆弱性情報(Moderate: CVE-2021-44224, High: CVE-2021-44790)が公開され、修正版のApache HTTP Server 2.4.52がリリースされました。今回はこちらの脆弱性の概要と、各ディストリビューションの情報を纏めています。




Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2021-44224 2.4.7 <= apache <= 2.4.51

Vendor: Moderate

CVE-2021-44790 apache <= 2.4.51

Vendor: High

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44224
    • アプリケーションのクラッシュ、またはSSRF攻撃の成功
    • Apache HTTP サーバー 2.4.7から2.4.51までのバージョンでは、フォワードプロキシ(ProxyRequests On)として設定されているhttpdに細工されたURIを送ることによりクラッシュ(NULLポインタ被参照)を起こします。また、フォワードプロキシとリバースプロキシの混合状態として設定している場合には、リクエストがUnixドメインソケットの終端に直接届くことを許可してしまうSSRF(Server Side Request Forgery)攻撃を引き起こしてしまう可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44790
    • マルチパートコンテキストをmod_luaで処理する際のバッファーオーバーフロー
    • 2.4.51以前のバージョンのApache HTTP サーバでは、注意深く細工されたリクエストボディによりmod_luaマルチパートパーサ(Luaスクリプトからのr:parsebody()呼び出し)でバッファーオーバーフローが引き起こされる可能性があります。現在の所Apache httpdチームはこの脆弱性の悪用は認識していません。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

セミナー情報1

2021/10/22日に大阪商工会議所様が開催致しました「BCP・サイバーセキュリティセミナー「やってはイケナイ」をやってみる!」ですが、Youtube動画が公開されています。筆者も登壇しましたので、ご興味がありましたらぜひ見て下さい。

前へ

SELinux/iptablesとApache Log4jの任意のコード実行の脆弱性(Log4Shell: CVE-2021-44228)

次へ

System Security Services Daemon: SSSDの脆弱性(Important: CVE-2021-3621 )