containerdの脆弱性(Moderate: CVE-2022-23648)と新バージョン(1.4.13, 1.5.10, 1.6.1)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/11/2022にcontainerdの脆弱性(Moderate: CVE-2022-23648)と新バージョン(1.4.13, 1.5.10, 1.6.1)が公開されていました。少し遅くなりましたが、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-23648 <= 1.4.12, 1.5.0 - 1.5.9, 1.6.0 containerd CRI plugin: Insecure handling of image volumes

Vendor: Moderate

Red Hat: 7.4 Important

Red Hat: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23648
    • 情報が漏洩する可能性
    • containerdのCRI実装で特別に細工されたイメージ設定によりホスト上の任意のファイルやディレクトリに対してRead-Onlyのアクセスを得ることが可能です。これによりコンテナのポリシー(Kubernetes Pod Security Policy等)を迂回することが可能になり、重要な情報が読まれる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

Linux Kernelの脆弱性(Important: CVE-2022-0995)

次へ

Spring Frameworkの脆弱性(Spring4Shell / SpringShell : CVE-2022-22965)