containerdの脆弱性(Moderate: CVE-2022-31030)と新バージョン(1.5.13, 1.6.6)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

06/07/2022にcontainerdの脆弱性(Moderate: CVE-2022-31030)と新バージョン(1.5.13, 1.6.6)が公開されていました。少し遅くなりましたが、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-31030 < 1.5.13 , >= 1.6.0 < 1.6.6

containerd CRI plugin: Host memory exhaustion through ExecSync

Vendor: Moderate

Red Hat: 5.5 Moderate

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31030
    • ホストメモリの枯渇
    • containerdのCRI実装で、コンテナの中のプログラムがExecSyncAPIを呼び出すことにより、containerdデーモンがバウンドされていないメモリを消費する事がわかりました。これによりホストのメモリが枯渇する可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

PostgreSQLの脆弱性情報(Important: CVE-2022-1552)と新バージョン(14.3, 13.7, 12.11, 11.16, 10.21)

次へ

Apache HTTP Serverの脆弱性情報(Moderate: CVE-2022-26377, Low: CVE-2022-28330, CVE-2022-28614, CVE-2022-28615, CVE-2022-29404, CVE-2022-30522, CVE-2022-30556, CVE-2022-31813 )と2.4.54リリース