cpioの脆弱性情報(Moderate: CVE-2019-14866)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/05/2019にcpioの脆弱性情報(Moderate: CVE-2019-14866)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




一次情報源

CVE番号 影響するバージョン リファレンス Priority CVSS
CVE-2019-14866 2.13より前のバージョン

Bug 1765511 (CVE-2019-14866) - CVE-2019-14866 cpio: improper input validation when writing tar header fields leads to unexpect tar generation

Red Hat: 6.7 MEDIUM

Red Hat: Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14866
    • 入力値の不適切なチェックによるシステム侵害の可能性
    • 2.13より前の全てのバージョンのcpioでは、TARアーカイブを生成する際に入力値を適切にチェックしていませんでした。cpioが攻撃者により書き込みができるパスからTARアーカイブを作成する際には、作成されたアーカイブに攻撃者がパーミッションを持っていなかったはずのパスにファイルが含まれている可能性があります。これを高位の権限を持つユーザが注意せずに展開してしまうことで、システムが侵害される可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの複数の脆弱性情報(CVE-2019-19965, CVE=2019-19966, CVE-2019-20054, CVE-2019-20095, CVE-2019-20096)

次へ

phpMyadminの脆弱性情報(Serious(深刻): CVE-2020-5504)