Dogtag PKIの脆弱性(CVE-2018-1080)




06/28/2018にDogtag PKIの脆弱性情報(CVE-2018-1080)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


 

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

06/28/2018にDogtag PKIの脆弱性情報(CVE-2018-1080)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate(CVE-2018-1080)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1080
    • allowルールとdenyルールの取り違え

    • 重要度 - Moderate

    • 10.6.1までのDogtag PKIでは、AAclAuthz.javaに脆弱性が有り、一定の設定に置いてACLのアプリケーションがallowとdenyのルールを取り違えてしまうことがわかりました。サーバがallowルールをdenyルールの前に処理するように設定されていた場合(authz.evaluateOrder=allow,deny)、allowルールはdenyアクセスとなりdenyルールはgrantアクセスを与えられます。これにより特権の昇格やその他に利用される可能性が有ります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteやKatello、Spacewalk等を使うと管理が便利でしょう。

[参考]

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1080

セキュリティ系連載案内


セミナー情報

2018年07月13日 (金) 19:00から、「OSSセキュリティ技術の会 第三回勉強会 (副題:"Keycloak"で、"認証王"に!!!おれはなるっ!!!!)」 と題しまして、OSS認証基盤のKeycloakに特化した話をさせて頂きます。

https://secureoss-sig.connpass.com/event/90917/がプログラム内容と申し込みの詳細になりますので、是非お申し込み下さい。

前へ

Linux Kernelの複数のLowの脆弱性(CVE-2018-13093, CVE-2018-13094, CVE-2018-13095, CVE-2018-13096, CVE-2018-13097, CVE-2018-13098, CVE-2018-13099, CVE-2018-13100)

次へ

Linux Kernelの脆弱性(CVE-2018-10872)