Gitに関しての脆弱性情報 ( Important: CVE-2018-17456 )と更新バージョン (Git 2.14.5, 2.15.4, 2.16.5, 2.17.2, 2.19.1)



10/05/2018に、gitに関しての脆弱性情報 (Important: CVE-2018-17456 )と更新バージョン (Git 2.14.5, 2.15.4, 2.16.5, 2.17.2, 2.19.1)が出ています。今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

10/05/2018に、gitに関しての脆弱性情報 (Important: CVE-2018-17456 )と更新バージョン (Git 2.14.5, 2.15.4, 2.16.5, 2.17.2, 2.19.1)が出ています。今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

  • CVE-2018-17456
    • Important
    • CVSS Severity (version 3.0):
      • Red Hat Customer Portal
        • CVSS v3 Base Score: 8.8
        • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
      • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2018-17456
    • gitサーバ上での任意のコマンド実行の可能性
    • 重要度 - Important
    • gitで、"git clone --recurse-submodules"を実行した際に、Gitは与えられた.gitmodulesファイルをURLフィールドのためにパースして、引数として"git clone"サブプロセスに無条件に渡します。URLフィールドが"-"で始まる場合、"git clone"サブプロセスはURLをオプションとして扱ってしまいます。これにより、"git clone"を実行したユーザによって、スーパープロジェクトでスクリプトとして提供された任意のスクリプトを実行することが出来ます。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生する場合には、peacemakerなどOSSのクラスタ製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

[Announce] Git 2.14.5, 2.15.3, 2.16.5, 2.17.2, 2.18.1, and 2.19.1

セキュリティ系連載案内


セミナー情報 1

2018年10月22日から10月25日のCSS(Computer Security Symposium)2018で、「OSSセキュリティ技術ワークショップ(OWS) 2018特別セッション」 と題しまして、OSSセキュリティ技術の会後援で特別セッションを開催します。

https://www.iwsec.org/ows/2018/index.htmlにプログラム内容と一般論文申し込みの詳細を載せていきますので、是非御確認下さい(ページは更新中です)。



セミナー情報

2018/11/05 19:00に、「2018年秋のBPFまつり」と題しまして、OSSセキュリティ技術の会 第四回勉強会を行います。

今回のテーマはBPF(Berkeley Packet Filter)になります。

https://secureoss-sig.connpass.com/event/103763/がプログラム内容と申し込みの詳細になります。奮ってご参加下さい。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Tomcat 7.x/8.x/9.xに関しての脆弱性情報 ( Medium: CVE-2018-11784 )

次へ

Linux Kernelの脆弱性情報(ARM: CVE-2018-18021)