gitの脆弱性 ( CVE-2017-14867 ) — | サイオスOSS | サイオステクノロジー

gitの脆弱性 ( CVE-2017-14867 ) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / gitの脆弱性 ( CVE-2017-14867 )

gitの脆弱性 ( CVE-2017-14867 )

9/26に、gitに関しての脆弱性情報 ( CVE-2017-14867 )が出ています。今回は、これらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

9/26に、gitに関しての脆弱性情報 ( CVE-2017-14867 )が出ています。今回は、これらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Important

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2017-14867

    • gitサーバ上での任意のコマンド実行の可能性

    • 重要度 - Important

    • Git 2.10.5, 2.11.4より前の2.11.x, 2.12.5より前の2.12.x, 2.13.6より前の2.13.x, 2.14.2より前の2.14.xでは、gitのサブコマンド(cvsserver等)で、攻撃者がシェルのメタキャラクターを使ったモジュール名を通して任意のOSコマンドを実行することを許可する、安全でないPerlスクリプトを使用しています。攻撃用のコードはCVSをサポートしていないgit-shellを用いても実行されます。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

[参考]

[ANNOUNCE] Git v2.13.6 and others


セミナー情報

10/12(水)に「OSSインフラナイターvol.2」と題して、インフラ関連のセミナーを行います。この回では、『OSSエキスパート鼎談シリーズ: ここだけでしか聞けないAnsibleの話 』と題してAnsibleの最新動向から実際の効果を、鼎談を交えて説明致します。

今回も、前回に引き続き、ゲスト講師をお招きし講演をいただきます。

https://connpass.com/event/67715/がプログラム内容と申し込みの詳細になりますので、是非お申し込み下さい。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

関連コンテンツ
Gitの脆弱性 ( CVE-2017-1000117 )
タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

Linux Kernelの脆弱性(CVE-2018-5703) — | サイオスOSS | サイオステクノロジー

次へ

bind 9に緊急の脆弱性(CVE-2015-8704, CVE-2015-8705) — | サイオスOSS | サイオステクノロジー