glibcの脆弱性(CVE-2017-16997) — | サイオスOSS | サイオステクノロジー

glibcの脆弱性(CVE-2017-16997) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / glibcの脆弱性(CVE-2017-16997)

glibcの脆弱性(CVE-2017-16997)

12/18/2017に、glibcの脆弱性が公開されました(CVE-2017-16997)。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

12/18/2017に、glibcの脆弱性が公開されました(CVE-2017-16997)。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

Medium/Moderate(CVE-2017-16997)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16997
    • ローカルユーザの特権昇格の可能性

    • 重要度 - Moderate/Medium

    • 2.1.9〜2.2.6までのglibcでは、elf/dl-load.c中で特権(setuidまたはAT_SECURE)プログラムの為の、$ORIGINを含むRPATHとRUNPATH降の扱いに問題がありました。これにより、ローカルユーザがトロイの木馬ライブラリなどを介して特権を得ることが可能になります。これは、空のRPATH/RUNPATHトークンを"./"ディレクトリとして誤って解釈することから起因しています。注意:特権プログラムへのRPATH/RUNPATHの設定は非常に珍しいもので、殆どの場合、そのようなプログラムは一般的なLinuxディストリビューションと一緒には同梱されていません。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、アプリケーションやOSの再起動が発生する場合には、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16997

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

phpMyAdminの脆弱性(CVE-2018-10188) — | サイオスOSS | サイオステクノロジー

次へ

linux kernelの脆弱性( CVE-2017-7895 ) — | サイオスOSS | サイオステクノロジー