GNU Patchの複数の脆弱性情報(Medium: CVE-2019-13636, CVE-2019-13638)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

07/27/2019にGNU Patchの複数の脆弱性情報(Medium: CVE-2019-13636, CVE-2019-13638)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2019-13636
    • SuSE
      • CVSS v3 Base Score: 3.9(Low)
      • Vector: AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 5.9(Moderate)
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
    • NVD
      • CVSS v3 Base Score: 5.9 Medium
      • Vector: AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
      • CVSS v2 Base Score: 5.8 Medium
      • Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:P)
  • CVE-2019-13638
    • SuSE
      • CVSS v3 Base Score: 7.3(Important)
      • Vector: AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
    • Red Hat Customer Potal
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13636
    • シンボリックリンク処理の問題
    • 重要度 - Moderate/Medium
    • 影響する範囲:2.7.6までのGNU Patch
    • 2.7.6までのGNU Patchでは特定の入力ファイルでシンボリックリンクを誤って処理してしまう問題があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13638
    • シェルコマンドインジェクションの可能性
    • 重要度 - Important
    • 影響する範囲:2.7.6までのGNU Patch
    • 2.7.6までのGNU PatchでOSコマンドインジェクションの脆弱性が存在し、edスタイルのdiffペイロードにシェルのメタキャラクタが埋め込まれているような細工されたパッチファイルを開く事で悪用されます。脆弱性のあるバージョンを使っているシステムにedエディタがインストールされている必要はありません。これはCVE-2018-1000156とは別の問題です。


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


セミナー情報1

コンピュータセキュリティシンポジウム2019(長崎)が2019年10月21日(月) ~ 10月24日(木)で開催されます。

こちらですが、OSSセキュリティ技術の会も後援になっております。

また、Call For Papersで論文も募集しております。 オープンソースソフトウェア(OSS)セキュリティ技術トラック(略称:OWSトラック) も用意しております。

興味のある方は、是非チャレンジして下さい。

https://www.iwsec.org/css/2019/cfp.html

セミナー情報2

2019/07/31 10:00-17:00で開催される、一般社団法人 日本情報システム・ユーザ協会(JUAS)様による有料ハンズオンセミナー「ハンズオンで学ぶ!クラウド時代の運用管理とセキュリティ対策 」にて当ブログの筆者「面 和毅」が講師を努めます。

本セミナーでは、大手ベンダーや外資系企業、ユーザー企業などでセキュリティの専門家として20年以上の経験を持ち、現在、セキュリティエバンジェリストとして活躍する講師が実体験を交えながら、クラウド上のサーバーを安価に守る方法を、演習をまじえ、具体的にお伝えします。

https://juasseminar.jp/seminars/view/4119290にて申し込みを行っております。奮ってご参加ください。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性情報(Moderate: CVE-2019-14283, CVE-2019-14284)

次へ

Qemuの脆弱性情報(Important: CVE-2019-14378)