HAProxyの脆弱性情報(Moderate: CVE-2018-20102, Important: CVE-2018-20103)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/14/2018にHAProxyの脆弱性情報(Moderate: CVE-2018-20102, Important: CVE-2018-20103)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2018-20102

    Moderate

    • SuSE
      • CVSS v3 Base Score: 6.5
      • Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 6.5
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
    • NVD
  • CVE-2018-20103

    Important

    • SuSE
      • CVSS v3 Base Score: 7.5
      • Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 7.5
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20102
    • 境界外読み込みの可能性
    • 重要度 - Moderate
    • 1.8.14までのHAProxyで、dns.c中のdns_validate_dns_response()で境界外読み込みが見つかりました。DNSレスポンスを検証する際にチェックを怠っていたため、リモートの攻撃者が、accepted_payload_sizeの値に依存してバッファの初期化されていない場所や、スタックに残っているもの、過去の8193バイトのバッファの最後などににアクセスすることにより、AAAAレコードに該当する部分を読み取ることが出来ます。
    • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20103
      • スタックの消費
      • 重要度 - Important
      • 1.8.14までのHAProxyで、dns.c中に問題が見つかりました。圧縮されたポインタの場合、細工されたパケットによりポインタからポインタ自身を再帰的にポイントするようにすることが出来たり、長いチェーンの有効なポインタを作ることでスタックの消費を行うことが出来ます。


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

セキュリティ系連載案内


セミナー情報

2019/01/09 18:30-20:30で、「OSSライセンスMeetup Vol.1」を行います。

今回は技術評論社刊「OSSライセンスの教科書」著者・上田さんを迎えて刊行に至った理由・本著に込めた思い・見どころなどを語っていただき、後半ではテクニカルライター可知豊さんと共に上田さんと本書についてのディスカッションを行います。

https://sios.connpass.com/event/104422/がプログラム内容と申し込みの詳細になります。奮ってご参加下さい。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性情報(Moderate: CVE-2018-18397)

次へ

Go言語の脆弱性情報(Important: CVE-2018-16873, Moderate: CVE-2018-16874, CVE-2018-16875)