HAProxyの脆弱性情報(Critical: CVE-2020-11100)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

04/02/2020にHAProxyの脆弱性情報(Critical: CVE-2020-11100)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


[過去の関連リンク(最新5件)]



Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2020-11100 1.8 <= HAProxy < 2.1.4

Red Hat: 8.8 Critical

NVD: 8.8 High

Red Hat: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

NVD : CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11100
    • リモートコード実行の可能性
    • 1.8から2.1.3までのHAProxyでは、HPACKデコーダのhpack-tbl.c中のhpack_dht_insert()に問題があり、細工されたHTTP/2リクエストを用いてリモートの攻撃者がヒープ中に任意のバイトを書き込む事が出来ます。これにより、リモートコード実行の可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

GnuTLSの脆弱性情報(High: CVE-2020-11501)

次へ

Kubernetes(kube-apiserver) の脆弱性情報(CVE-2019-11254)