Oracle Javaの脆弱性(Oracle Critical Patch Update Advisory - Jul 2022)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

07月19日に四半期恒例のOracle Critical Patch UpdateでOracle Javaの脆弱性(CVE-2022-34169 CVE-2022-25647 CVE-2022-21541 CVE-2022-21540 CVE-2022-21549)が公開されました。今回はこちらのJavaの脆弱性についてまとめてみます。


情報は分かり次第追記・更新します。



CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2022-34169
    • 影響するバージョン:Oracle Java SE: 7u343, 8u333, 11.0.15.1, 17.0.3.1, 18.0.1.1; Oracle GraalVM Enterprise Edition: 20.3.6, 21.3.2, 22.1.0
    • サブコンポーネント: JAXP (Xalan-J)
    • CVSS 3.0 Base Score 7.5
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-25647
    • 影響するバージョン:Oracle GraalVM Enterprise Edition: 20.3.6, 21.3.2, 22.1.0
    • サブコンポーネント: Native Image (Gson)
    • CVSS 3.0 Base Score 6.2
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21541
    • 影響するバージョン:Oracle Java SE: 7u343, 8u333, 11.0.15.1, 17.0.3.1, 18.0.1.1; Oracle GraalVM Enterprise Edition: 20.3.6, 21.3.2, 22.1.0
    • サブコンポーネント: Hotspot
    • CVSS 3.0 Base Score 5.9
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21540
    • 影響するバージョン:Oracle Java SE: 7u343, 8u333, 11.0.15.1, 17.0.3.1, 18.0.1.1; Oracle GraalVM Enterprise Edition: 20.3.6, 21.3.2, 22.1.0
    • サブコンポーネント: Hotspot
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21549
    • 影響するバージョン:Oracle Java SE: 17.0.3.1; Oracle GraalVM Enterprise Edition: 21.3.2, 22.1.0
    • サブコンポーネント: Libraries
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生しますので、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

セミナー情報1

2022/06/24にこちらのセミナーで「最近の状況を鑑みた脆弱性対策の重要性について」として2022-Q1の脆弱性の情報を入れながら、脆弱性対策についてお話します。ご興味がありましたらぜひご参加下さい。

前へ

Linux Kernelに脆弱性(Moderate: CVE-2022-2380 )

次へ

MySQLの脆弱性(Oracle Critical Patch Update Advisory - Jul 2022)