Oracle Javaの脆弱性(Oracle Critical Patch Update Advisory - Oct 2022)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

10月18日に四半期恒例のOracle Critical Patch UpdateでOracle Javaの脆弱性(CVE-2022-32215 CVE-2022-21634 CVE-2022-21597 CVE-2022-21628 CVE-2022-21626 CVE-2022-21618 CVE-2022-39399 CVE-2022-21624 CVE-2022-21619)が公開されました。遅くなりましたが、今回はこちらのJavaの脆弱性についてまとめてみます。


情報は分かり次第追記・更新します。



CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2022-32215
    • 影響するバージョン:Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: Node (Node.js)
    • CVSS 3.0 Base Score 9.1
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21634
    • 影響するバージョン:Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: LLVM Interpreter
    • CVSS 3.0 Base Score 7.5
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21597
    • 影響するバージョン:Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: JavaScript
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21628
    • 影響するバージョン:Oracle Java SE: 8u341, 8u345-perf, 11.0.16.1, 17.0.4.1, 19; Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: Lightweight HTTP Server
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21626
    • 影響するバージョン:Oracle Java SE: 8u341, 8u345-perf, 11.0.16.1; Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: Security
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21618
    • 影響するバージョン:Oracle Java SE: 17.0.4.1, 19; Oracle GraalVM Enterprise Edition: 21.3.3, 22.2.0
    • サブコンポーネント: JGSS
    • CVSS 3.0 Base Score 5.3
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-39399
    • 影響するバージョン:Oracle Java SE: 11.0.16.1, 17.0.4.1, 19; Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: Networking
    • CVSS 3.0 Base Score 3.7
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21624
    • 影響するバージョン:Oracle Java SE: 8u341, 8u345-perf, 11.0.16.1, 17.0.4.1, 19; Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: JNDI
    • CVSS 3.0 Base Score 3.7
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。
  • CVE-2022-21619
    • 影響するバージョン:Oracle Java SE: 8u341, 8u345-perf, 11.0.16.1, 17.0.4.1, 19; Oracle GraalVM Enterprise Edition: 20.3.7, 21.3.3, 22.2.0
    • サブコンポーネント: Security
    • CVSS 3.0 Base Score 3.7
    • CVSS Vector: 元情報参照
    • 情報は詳細が分かり次第更新します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生しますので、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

セミナー情報

2022/11/01 16:30-18:00 にJAPANSecuritySummit Update Liveセションで「オープンソースの脆弱性とサプライチェーンのリスクを考える」を行います。

こちらが内容と参加申し込みの詳細になります。奮ってご参加下さい。

セミナー情報

今年も情報処理学会のCSS2022(有償)中でOWS2022を開催致します。

■開催期間 2022年10月24日(月) ~ 2022年10月27日(木)

■会場 熊本城ホールとオンライン(ZOOM)のハイブリッド開催

主催 一般社団法人 情報処理学会 コンピュータセキュリティ研究会(CSEC)

共催 一般社団法人 情報処理学会 セキュリティ心理学とトラスト研究会(SPT)

合同開催

OWS2022では、企画講演セッションの他に、招待講演として「タイトル:オープンソースソフトウェアをより安全にするための取組み」と題してLinux Foundationの方に講演いただきます。

他にもOSSのセキュリティに関する講演や論文発表が目白押しです。奮ってご参加ください。

参加費はこちら(OWSだけでなくCSS全てに参加することができます。

参加登録はこちら

前へ

Linux Kernelの脆弱性(CVE-2022-43750)

次へ

Ansibleの脆弱性(Moderate: CVE-2022-3697)