MIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710) — | サイオスOSS | サイオステクノロジー

MIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / MIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710)

MIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710)

1/17/2018にMIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

1/17/2018にMIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5709
    • Integer Overflowの脆弱性

    • 1.16までのMIT Kerberos 5(krb5)に問題が見つかりました。kadmin/dbutil/dump.c中の16-bitデータを保存する変数"dbentry->n_key_data"に32-bitデータを表す"u4"がアサインされています。攻撃者はこれを利用して、信頼できるデータが入っているKerberosデータベースのダンプファイルに影響を与える可能性が有ります。

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5710
    • DoSの可能性

    • 1.16までのMIT Kerberos 5(krb5)に問題が見つかりました。KDC(Key Distribution Center)のplugins/kdb/ldap/libkdb_ldap/ldap_principal2.cで、事前に定義された関数からstrlenにNULL値が入る可能性が有ります。これにより、DoS(ヌルポインタ非参照)が発生する可能性が有ります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5709

セキュリティ系連載案内


セミナー情報

著者が所属しているOSSセキュリティ技術の会では、02/23/(金)に「3コマ連続 [セキュリティトラック] OSSと脆弱性管理」と題して、OSSの利用と脆弱性管理に関しての、パネルディスカッションを含めたセッションを行います。

https://www.ospn.jp/osc2018-spring/modules/eguide/event.php?eid=49がプログラム内容の詳細になりますので、是非お申し込み下さい。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

Cactiの複数の脆弱性(CVE-2017-16641, CVE-2017-16660, CVE-2017-16661) — | サイオスOSS | サイオステクノロジー

次へ

ruby gem Net::LDAPの脆弱性 (CVE-2017-17718) — | サイオスOSS | サイオステクノロジー