Linux Kernelの脆弱性(Blueborne: CVE-2017-1000251) — | サイオスOSS | サイオステクノロジー

Linux Kernelの脆弱性(Blueborne: CVE-2017-1000251) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / Linux Kernelの脆弱性(Blueborne: CVE-2017-1000251)

Linux Kernelの脆弱性(Blueborne: CVE-2017-1000251)

09/12/2017にLinux Kernelの脆弱性情報(CVE-2017-1000251)が公開されています。Importantの脆弱性ですので、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。 (注) Red Hat社の方でも注意喚起のページがありましたのでリンクします。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

09/12/2017にLinux Kernelの脆弱性情報(CVE-2017-1000251)が公開されています。Importantの脆弱性ですので、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

(注) Red Hat社の方でも注意喚起のページがありましたのでリンクします。





Priority

Important

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000251
    • システムのクラッシュまたはring 0(kernel)権限によるリモートコード実行の可能性

    • 重要度 - Important

    • Linux Kernel 3.3-rc1から4.13.1までのBluetoothサブシステムにスタックバッファーフローの欠陥が見つかりました。システムへのBluetooth経由で接続を開始出来る、認証されていない攻撃者は、kernelではスタック保護機能が有効になっている(CONFIG_CC_STACKPROTECTOR=yで、s390xとppc64[ie]以外では有効になっている)ので、殆どのコード実行は不可能ですが、少なくともシステムをクラッシュさせることが出来ます。可能性は低いですが、スタック保護機能の性質上、CONFIG_CC_STACKPROTECTORでも完全にコードの実行を防ぐことは出来ません。スタック保護機能がないシステム(ppc64[ie]やs390x)では、この欠陥を用いてリモートの攻撃者がBluetooth経由でring 0(kernel)権限によるリモートコード実行をできる可能性が有ります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

https://access.redhat.com/security/cve/CVE-2017-1000251

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000251

セキュリティ系連載案内

OSSセキュリティ技術の会による日経Linuxでの連載「IoT時代の最新SELinux入門」がITPro上で読めるようになりました。技術の会代表で第一人者である中村さん等による、最新のSELinuxの情報やコマンド類等も更新されているのでお薦めです。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

ka-omo@tor
タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

OpenSSLの脆弱性 ( CVE-2017-3737, CVE-2017-3738 ) — | サイオスOSS | サイオステクノロジー

次へ

Zabbixの脆弱性( CVE-2017-2824 ) — | サイオスOSS | サイオステクノロジー