Linux Kernelの脆弱性(CVE-2018-7480) — | サイオスOSS | サイオステクノロジー

Linux Kernelの脆弱性(CVE-2018-7480) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / Linux Kernelの脆弱性(CVE-2018-7480)

Linux Kernelの脆弱性(CVE-2018-7480)

02/25/2018にLinux Kernelの脆弱性情報(CVE-2018-7480)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

02/25/2018にLinux Kernelの脆弱性情報(CVE-2018-7480)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7480
    • ローカルユーザによるDoS(double free)の可能性

    • 4.11以前のLinux Kernelでは、block/blk-cgroup.c中のblkcg_init_queue()関数に問題が有り、ローカルユーザによるDoS(double free)を行われる可能性が有ります。

      これに関する修正は以下の箇所になります。

      diff --git a/block/blk-cgroup.c b/block/blk-cgroup.c
      index 37fe595..295e98c2 100644
      --- a/block/blk-cgroup.c
      +++ b/block/blk-cgroup.c
      @@ -1079,10 +1079,8 @@ int blkcg_init_queue(struct request_queue *q)
       	if (preloaded)
       		radix_tree_preload_end();
       
      -	if (IS_ERR(blkg)) {
      -		blkg_free(new_blkg);
      +	if (IS_ERR(blkg))
       		return PTR_ERR(blkg);
      -	}
       
       	q->root_blkg = blkg;
       	q->root_rl.blkg = blkg;
      

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7480

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

linux kernelの複数の脆弱性( CVE-2016-10153, CVE-2016-10154, CVE-2017-5547, CVE-2017-5548, CVE-2017-5549, CVE-2017-5550, CVE-2017-5551) — | サイオスOSS | サイオステクノロジー

次へ

NetworkManagerの脆弱性(CVE-2018-1000135) — | サイオスOSS | サイオステクノロジー