Linux Kernelの脆弱性(CVE-2017-18241) — | サイオスOSS | サイオステクノロジー

Linux Kernelの脆弱性(CVE-2017-18241) — | サイオスOSS | サイオステクノロジー

現在位置: ホーム / セキュリティ ブログ / Linux Kernelの脆弱性(CVE-2017-18241)
 

Linux Kernelの脆弱性(CVE-2017-18241)

03/22/2018にLinux Kernelの脆弱性情報(CVE-2017-18241)が公開されています。実際には、2017/07/04に修正されていた物に番号が振られたという形になります。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。
 


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/22/2018にLinux Kernelの脆弱性情報(CVE-2017-18241)が公開されています。実際には、2017/07/04に修正されていた物に番号が振られたという形になります。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18241
    • DoS(Nullポインタ非参照)とKernel Panicの可能性

    • 重要度 - Moderate

    • 4.13までのLinux Kernelの、fs/f2fs/segment.c中では、noflush_mergeオプションを使うことにより、flush_cmd_controlデータ構造体にNULL値が入り、結果としてNULLポインタ非参照とKernel Panicが発生する可能性が有ります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18241

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

Linux Kernelの脆弱性(CVE-2017-1000253) — | サイオスOSS | サイオステクノロジー

次へ

linux kernelの複数の脆弱性( CVE-2016-10153, CVE-2016-10154, CVE-2017-5547, CVE-2017-5548, CVE-2017-5549, CVE-2017-5550, CVE-2017-5551) — | サイオスOSS | サイオステクノロジー