Linux Kernelの脆弱性(CVE-2018-10840)




07/17/2018にLinux Kernelの脆弱性情報(CVE-2018-10840)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


 

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

07/17/2018にLinux Kernelの脆弱性情報(CVE-2018-10840)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate(CVE-2018-10840)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10840
    • ヒープベースバッファーオーバーフローの脆弱性

    • 重要度 - Moderate

    • fs/ext4/xattr.cのext4_xattr_set_entry()関数にヒープベースバッファーオーバーフローの脆弱性が見つかりました。攻撃者は細工されたext4イメージをマウントすることでこの脆弱性を利用することが出来る可能性があります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteやKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10840

セキュリティ系連載案内

前へ

Speculative Bounds Check Bypass Store : BCBS (INTEL-OSS-10002 : CVE-2018-3693)

次へ

antの脆弱性(CVE-2018-10886)