Linux Kernelの脆弱性情報(Moderate: CVE-2019-9162)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/01/2019にLinux Kernelの脆弱性情報(Moderate: CVE-2019-9162)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。





Priority

  • CVE-2019-9162

    Moderate

    • SuSE
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 5.3
      • Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
    • NVD
      • CVSS v3 Base Score: 7.8 High
      • Vector: AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

      CVSS Severity (version 2.0):

      • CVSS v2 Base Score: 4.6 Medium
      • Vector: (AV:L/AC:L/Au:N/C:P/I:P/A:P)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9162
    • 境界外読み込み・書き込みによるDoS(OOPS)や権限昇格の可能性
    • 重要度 - Moderate
    • 4.20.2より前のLinux Kernelでは、SNMP NATモジュールのnet/ipv4/netfilter/nf_nat_snmp_basic_main.cでASN.1 lengthのチェックが不十分なため、境界外読み込み/書き込みを引き起こし、OOPSやローカルの権限昇格を引き起こす事が出来る可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

glibcの脆弱性情報(Moderate: CVE-2018-20796)

次へ

Sambaで使われるldbの脆弱性情報(Moderate: CVE-2019-3824)