Linux KernelのUSBに関する脆弱性情報(CVE-2019-15211,CVE-2019-15212,CVE-2019-15213,CVE-2019-15214,CVE-2019-15215,CVE-2019-15216,CVE-2019-15217,CVE-2019-15218,CVE-2019-15219,CVE-2019-15220,CVE-2019-15221,CVE-2019-15222,CVE-2019-15223,CVE-2019-15290,CVE-2019-15291)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

08/21/2019にLinux KernelのUSBに関する複数の脆弱性情報(Moderate: CVE-2019-15211, CVE-2019-15212, CVE-2019-15213, CVE-2019-15214, CVE-2019-15215, CVE-2019-15216, CVE-2019-15217, CVE-2019-15218, CVE-2019-15219, CVE-2019-15220, CVE-2019-15221, CVE-2019-15222, CVE-2019-15223, CVE-2019-CVE-2019-15290, CVE-2019-15291)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


昨日のLinux Kernelの複数の脆弱性情報もこちらに纏めて記載します。




Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2019-15211 5.2.6より前のLinux Kernel

Red Hat: Moderate

SuSE: Moderate

Red Hat: CVSS 7.3/CVSS Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:H

CVE-2019-15212 5.1.8より前のLinux Kernel

Red Hat: Moderate

SuSE: Moderate

Red Hat: CVSS 6.1/CVSS Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

SUSE: CVSS 5.7/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

CVE-2019-15213 5.2.3より前のLinux Kernel

Red Hat: Moderate

SuSE: Moderate

Red Hat: CVSS 6.1/CVSS Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

SUSE: CVSS 5.2/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

CVE-2019-15214 5.0.0より前のLinux Kernel

Red Hat: Moderate

SuSE: Moderate

Red Hat: CVSS 6.1/CVSS Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

CVE-2019-15215 5.2.6より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.9/CVSS Vector: AV:P/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

CVE-2019-15216 5.0.14より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.9/CVSS Vector: AV:P/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

CVE-2019-15217 5.2.3より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2019-15218 5.1.8より前のLinux Kernel

SuSE: Moderate

Red Hat: CVSS 7.3/CVSS Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2019-15219 5.1.8より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2019-15220 5.2.1より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 5.2/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

CVE-2019-15221 5.1.17より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:H

CVE-2019-15222 5.2.8より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2019-15223 5.1.8より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2019-15290 5.2.9より前のLinux Kernel

SuSE: Moderate

CVE-2019-15291 5.2.9より前のLinux Kernel

SuSE: Moderate

SUSE: CVSS 4.6/CVSS Vector: AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15211
    • use-after-freeの可能性
    • 5.2.6より前のLinux Kernelでは、drivers/media/radio/radio-raremono.c でメモリをきちんとアロケートしていなかったため、悪意のあるUSBデバイスドライバ(drivers/media/v4l2-core/v4l2-dev.c)によりuse-after-freeが引き起こされる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15212
    • double-freeの可能性
    • 5.1.8より前のLinux Kernelでは、drivers/usb/misc/rio500.cドライバに、悪意のあるUSBデバイスがdouble-freeを引き起こす事が出来る可能性が有馬す。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15213
    • use-after-freeの可能性
    • 5.2.3より前のLinux Kernelでは、drivers/media/usb/dvb-usb/dvb-usb-init.cに問題があり、悪意のあるUSBデバイスによりuse-after-freeが引き起こされる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15214
    • use-after-freeの可能性
    • 5.0.0より前のLinux Kernelでは、sound/core/init.c and sound/core/info.cに関係してカードの切断時に構造体の削除が早すぎるため、サウンドサブシステムでuse-after-freeを引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15215
    • use-after-freeの可能性
    • 5.2.6より前のLinux Kernelでは、drivers/media/usb/cpia2/cpia2_usb.ccに問題があり、悪意のあるUSBデバイスがuse-after-freeを引き起こすことができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15216
    • NULLポインタ被参照の問題
    • 5.0.14より前のLinux Kernelでは、drivers/usb/misc/yurex.cに問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こすことができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15217
    • NULLポインタ被参照の問題
    • 5.2.3より前のLinux Kernelでは、drivers/media/usb/zr364xx/zr364xx.cに問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15218
    • NULLポインタ被参照の問題
    • 5.1.8より前のLinux Kernelでは、drivers/media/usb/siano/smsusb.cに問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15219
    • NULLポインタ被参照の問題
    • 5.1.8より前のLinux Kernelでは、drivers/usb/misc/sisusbvga/sisusb.cに問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15220
    • use-after-freeの可能性
    • 5.2.1より前のLinux Kernelでは、drivers/net/wireless/intersil/p54/p54usb.cに問題があり、悪意のあるUSBデバイスによりuse-after-freeが引き起こされる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15221
    • NULLポインタ被参照の問題
    • 5.1.17より前のLinux Kernelでは、sound/usb/line6/pcm.c に問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15222
    • NULLポインタ被参照の問題
    • 5.2.8より前のLinux Kernelでは、sound/usb/helper.c に問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15223
    • NULLポインタ被参照の問題
    • 5.1.8より前のLinux Kernelでは、sound/usb/line6/driver.c に問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15290
    • NULLポインタ被参照の問題
    • 5.2.9より前のLinux Kernelでは、drivers/net/wireless/ath/ath6kl/usb.c 中のath6kl_usb_alloc_urb_from_pipe()関数に問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15291
    • NULLポインタ被参照の問題
    • 5.2.9より前のLinux Kernelでは、drivers/media/usb/b2c2/flexcop-usb.c 中のflexcop_usb_probe()関数に問題があり、悪意のあるUSBデバイスがNULLポインタ被参照を引き起こす事ができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


セミナー情報1

コンピュータセキュリティシンポジウム2019(長崎)が2019年10月21日(月) ~ 10月24日(木)で開催されます。

こちらですが、OSSセキュリティ技術の会も後援になっており、オープンソースソフトウェア(OSS)セキュリティ技術トラック(略称:OWSトラック) も用意しております。

セミナー情報2

"distro info": vol.1 と題しまして、各種ディストリビューションの情報を関係者から直接お届けするイベント「distro info」が開催されます。

今回は、先日リリースされたDebian10について、Debianの概要から含めての説明〜Debian10での特徴の紹介をします。ざっくり概要を把握されたい方から、発表者に確認の質問をしてみたい方までどうぞご参加下さい。

また、先月末にブラジルでDebian Conferenceが行われましたのでその紹介を行います。「Debianのカンファレンスってこんなのなんだな」というのを現地エピソードなど交えてお話します。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの複数の脆弱性情報(Moderate: CVE-2019-15211, CVE-2019-15212, CVE-2019-15213, CVE-2019-15214)

次へ

Squidの複数の脆弱性情報(Moderate: CVE-2019-12854, CVE-2019-12529, CVE-2019-12525)