Linux Kernelの脆弱性情報(Important: CVE-2020-10942)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/26/2020にLinux Kernelの脆弱性情報(Important: CVE-2020-10942)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2020-10942 Linux Kernel < 5.5.8 https://lkml.org/lkml/2020/2/15/125

RedHat: 7.4 Important

SuSE: 5.5 Moderate

RedHat: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

SuSE: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10942
    • Kernel Stack Corruptionの問題
    • 5.5.8より前のLinux Kernelでは、drivers/vhost/net.c中のget_raw_socketで、sk_familyフィールドの検証に問題がありました。攻撃者はこれを利用して細工されたシステムコールを用いてカーネルのスタック破損(stack-corruption)を引き起こす事ができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

phpMyadminの脆弱性情報(Moderate: CVE-2020-10802, CVE-2020-10803, CVE-2020-10804 )

次へ

Kubernetes の脆弱性情報(Moderate: CVE-2020-8551, CVE-2020-8552)