Linux Kernelの脆弱性情報(Moderate: CVE-2020-14314)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

09/16/2020にLinux Kernelの脆弱性情報(Moderate: CVE-2020-14314)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2020-14314 Linux kernel < 5.7.7 Bug 1853922 (CVE-2020-14314) - CVE-2020-14314 kernel: buffer uses out of index in ext3/4 filesystem

RedHat: 5.5 Moderate

RedHat: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14314
    • ローカルユーザによるシステムクラッシュの可能性
    • 5.9-rc2より前のLinux Kernelで、ext3/ext4ファイルシステム上でインデックスの壊れたディレクトリにアクセスした際に問題が見つかりました。これによりローカルの攻撃者がシステムをクラッシュすることができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

セミナー情報1

コンピュータセキュリティシンポジウム(CSS)2020併設のワークショップ、 OSSセキュリティ技術ワークショップ(OWS) 2020の企画講演セッション及び、 一般論文セッションの発表募集をさせていただきます。

今年度はオンラインでの開催となります。奮ってのご投稿、お待ちしております。

https://www.iwsec.org/ows/2020/


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性情報(Moderate: CVE-2020-14331)

次へ

Sambaの脆弱性情報(Critical: CVE-2020-1472 (ZeroLogon)と修正バージョン(4.12.7, 4.11.13, 4.10.18))