Linux Kernelのfbconでのバッファオーバー読み込みの脆弱性(Moderate: CVE-2020-28915)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/17/2020にLinux Kernelのfbconでバッファオーバー読み込みの脆弱性(Moderate: CVE-2020-28915)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2020-28915 Linux Kernel <= 5.9.2 Bug 1178886 - (CVE-2020-28915) VUL-0: CVE-2020-28915: kernel-source: kernel buffer overflow read in font handling

SuSE: Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-28915
    • fbconでのbuffer over-readの問題
    • 5.8.15以前のLinux Kernelでは、fbconコードのフレームバッファレイヤーでバッファオーバーリードの問題があり、ローカルの攻撃者がKernelメモリを読むことができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

PostgreSQLの脆弱性情報(CVE-2020-25694, CVE-2020-25695, CVE-2020-25696)と新バージョン(9.5.24, 9.6.20, 10.15, 11.10, 12.5, 13.1)

次へ

Linux Kernelのfbconでslab境界外読み込みの脆弱性(CVE-2020-28974)