Linux Kernelのfbconでslab境界外読み込みの脆弱性(CVE-2020-28974)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/22/2020にLinux Kernelのfbconでslab境界外読み込みの脆弱性(CVE-2020-28974)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2020-28974 Linux Kernel <= 5.9.7 Linux kernel slab-out-of-bounds Read in fbcon

SuSE: Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-28974
    • fbconでのbuffer over-readの問題
    • 5.9.7より前のLinux Kernelでは、drivers/tty/vt/vt.c 中のKD_FONT_OP_COPYでfbconのslab境界外読み込みの問題があり、ローカルの攻撃者が特権情報を読んだりKernelをクラッシュさせることができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelのfbconでのバッファオーバー読み込みの脆弱性(Moderate: CVE-2020-28915)

次へ

Intel(R) PROSet/Wireless WiFi 製品の脆弱性(High: INTEL-SA-00402, Critical: INTEL-SA-00403)