Linux Kernelの脆弱性(Moderate: CVE-2021-29646, CVE-2021-29648, CVE-2021-29649, CVE-2021-29650, Low: CVE-2021-29647)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/30/2021にLinux Kernelの脆弱性(Moderate: CVE-2021-29646, CVE-2021-29648, CVE-2021-29649, CVE-2021-29650, Low: CVE-2021-29647)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2021-29646 Linux Kernel < 5.11.11 https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.11

Red Hat: 6.2 Moderate

Red Hat: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2021-29647 Linux Kernel < 5.11.11 https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.11

Red Hat: 4.0 Low

Red Hat: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

CVE-2021-29648 Linux Kernel < 5.11.11 https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.11

Red Hat: 6.2 Moderate

Red Hat: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2021-29649 Linux Kernel < 5.11.11 https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.11

Red Hat: 6.2 Moderate

Red Hat: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2021-29650 Linux Kernel < 5.11.11 https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.11

Red Hat: 6.2 Moderate

Red Hat: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29646
    • Linux Kernelの5.11.11までのバージョンに脆弱性が見つかりました。net/tipc/node.c中のtipc_nl_retrieve_key()ではデータサイズをきちんと検証していませんでした。
  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29647
    • Linux Kernelの5.11.11までのバージョンに脆弱性が見つかりました。net/qrtr/qrtr.c中のqtr_recvmsg()に問題があり、部分的に初期化されないデータ構造体からカーネルメモリのセンシティブな情報を攻撃者が得ることが出来る可能性があります。
  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29648
    • Linux Kernelの5.11.11までのバージョンに脆弱性が見つかりました。resolved_idsとresolved_sizesがvmlinux BPF Type Format (BTF)で意図的に初期化されないことを考慮しません。これにより、予期しないアクセスによりシステムがクラッシュする可能性があります。
  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29649
    • Linux Kernelの5.11.11までのバージョンに脆弱性が見つかりました。kernel/usermode_driver.c と kernel/bpf/preload/bpf_preload_kern.c中でのクリーンアップステップの欠如から、user mode driver (UMD)のcopy_process()でメモリリークが発生します。
  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29650
    • Linux Kernelの5.11.11までのバージョンに脆弱性が見つかりました。net/netfilter/x_tables.c と include/linux/netfilter/x_tables.hでのメモリ保護の欠如により、netfilterサブシステムでDoS(panic)が発生する可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

CM

こちらで小学生の勉強支援サイトをオープンしました。算数のプリント(都度、自動生成)が無料でダウンロードできます。コンテンツは未だ少ないですが、徐々に増やしていきます。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

OpenSSLの脆弱性情報(High: CVE-2021-3449, CVE-2021-3450 )

次へ

(SAML第1回) SimpleSAMLphpを使った簡易IdPの作成