Linux Kernelの脆弱性(Important: CVE-2021-3501)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

05/06/2021にLinux Kernelの脆弱性(Important: CVE-2021-3501)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2021-3501 Bug 1950136 (CVE-2021-3501) - CVE-2021-3501 kernel: userspace applications can misuse the KVM API to cause a write of 16 bytes at an offset up to 32 GB from vcpu->run

Red Hat: 7.8 Important

Red Hat: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3501
    • KVM APIによる境界外書き込みの問題
    • Linux Kernelに問題が見つかりました。KVM APIでinternal.ndataの値がユーザプロセスによりアップデート可能なarrayインデックスにマップされており、これにより境界外書き込みの問題が発生します。これによる脅威としてデータの整合性やシステム可用性が侵害されます。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

CM

こちらで小学生の勉強支援サイトをオープンしました。算数のプリント(都度、自動生成)が無料でダウンロードできます。コンテンツは未だ少ないですが、徐々に増やしていきます。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(CVE-2021-31829)

次へ

Linux Kernelの複数の脆弱性(CVE-2021-3489, CVE-2021-3490, CVE-2021-3491)