Linux Kernelの脆弱性(Moderate: CVE-2021-43389)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/06/2021にLinux Kernelの脆弱性(Moderate: CVE-2021-43389)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

おじさん世代には懐かしい「ISDN」ドライバの脆弱性です。ある意味感無量。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2021-43389 Linux Kernel < 5.14.15

Bug 2013180 (CVE-2021-43389) - CVE-2021-43389 kernel: an array-index-out-bounds in detach_capi_ctr in drivers/isdn/capi/kcapi.c

Red Hat: 4.7 Moderate

Red Hat: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-43389
    • DoSの可能性
    • 5.14.15までのLinux Kernelではdrivers/isdn/capi/kcapi.c中のdetach_capi_ctr()関数にarray-index-out-of-boundsの問題があり、ユーザがioctlのCMTPCONNADDをコールする際に入力値の境界メモリ読み込みに関するチェックが不完全でした。ローカルユーザはこれを利用してシステムをクラッシュさせるなどのDoSを引き起こすことができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

セミナー情報1

2021/10/22日に大阪商工会議所様が開催致しました「BCP・サイバーセキュリティセミナー「やってはイケナイ」をやってみる!」ですが、Youtube動画が公開されています。筆者も登壇しましたので、ご興味がありましたらぜひ見て下さい。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(CVE-2021-43267)

次へ

ModSecurityの脆弱性情報(High: CVE-2021-35368)