Linux Kernelの脆弱性(CVE-2022-23222)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

01/16/2021にLinux Kernelの脆弱性(CVE-2022-23222)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-23222 Linux Kernel < 5.15.14

Linux Kernel eBPF Improper Input Validation Vulnerability

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23222
    • 特権昇格の可能性
    • 5.15.14までのLinux Kernelではkernel/bpf/verifier.cで幾つかの*_OR_NULLポインタタイプの計算に問題がありローカルの攻撃者はこれを利用して権限昇格をできる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

Linux Kernelの脆弱性(Important: CVE-2021-4155)

次へ

Libreswanの脆弱性(Important: CVE-2022-23094)