Linux Kernelの脆弱性(Important: CVE-2022-0185)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

01/19/2022にLinux Kernelの脆弱性(Important: CVE-2022-0185)が公開されていました。遅くなりましたが、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-0185

https://github.com/Crusaders-of-Rust/CVE-2022-0185

Red Hat: 7.8 Important

Red Hat:CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0185
    • 特権昇格の可能性
    • Linux KernelのFilesystem Contextで与えられたパラメータ長を確認するlegacy_parse_param()関数にヒープベースバッファーオーバーフローの脆弱性が見つかりました。非特権の(非特権ユーザネーム空間が有効になっているかCAP_SYS_ADMINケーパビリティが与えられている)ローカルユーザはファイルシステムをFilesystem Context APIを使わずにopenする事が出来、これによりシステムで特権昇格できる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

Linux Kernelの脆弱性(Moderate: CVE-2022-24958, CVE-2022-24959)

次へ

MariaDBの脆弱性(CVE-2022-24048, CVE-2022-24050, CVE-2022-24051, CVE-2022-24052)