Linux Kernelの脆弱性(Important: CVE-2022-25636)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

02/22/2022にLinux Kernelの脆弱性(Important: CVE-2022-25636)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-25636 5.4 <= Linux Kernel <= 5.6.10

Linux kernel: heap out of bounds write in nf_dup_netdev.c since 5.4

Red Hat: 7.8 Important

Red Hat: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-25636
    • 特権昇格の可能性
    • 5.16.10以前のLinux Kernelでは、net/netfilter/nf_dup_netdev.c中のnf_tables_offloadが関係する箇所でヒープ境界外書き込みによりローカルユーザが権限を昇格できる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

Linux Kernelの脆弱性(Moderate: CVE-2022-25258)

次へ

Cyrus SASLの脆弱性(Important: CVE-2022-24407)