Linux Kernelの脆弱性(Important: CVE-2022-0492)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/02/2022にLinux Kernelの脆弱性(Important: CVE-2022-0492)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-0492

Bug 2051505 (CVE-2022-0492) - CVE-2022-0492 kernel: cgroups v1 release_agent feature may allow privilege escalation

Red Hat: 7.0 Important

Red Hat: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0492
    • 特権昇格の可能性
    • kernel/cgroup/cgroup-v1.c中のcgroup_release_agent_write()関数に問題が見つかりました。この問題を利用して、限定的な環境においてcgroups v1 release_agent機能を用いて特権を昇格し制限された名前空間を脱出できる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

PHPの脆弱性情報(Moderate: CVE-2021-21708)と修正バージョン( 7.4.28, 8.0.16, 8.1.3 )

次へ

Linux Kernelの脆弱性(Important: CVE-2022-0847 (Dirty Pipe))