Linux Kernelの脆弱性(Important: CVE-2022-0995)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/26/2022にLinux Kernelの脆弱性(Important: CVE-2022-0995)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-0995

Bug 2063786 (CVE-2022-0995) - CVE-2022-0995 kernel: kernel bug in the watch_queue subsystem

Red Hat: 7.8 Important

Red Hat: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0995
    • ローカルからの権限昇格又はDoSの脆弱性
    • Linux Kernelのwatch_queueサブシステムに境界外メモリ書き込み(OOB)の脆弱性が見つかりました。ローカルユーザはこれを用いて権限を昇格させたりDoSを引き起こすことができる可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

RHEL9での変更点(セキュリティ編:Part1 SELinuxの無効化について)

次へ

containerdの脆弱性(Moderate: CVE-2022-23648)と新バージョン(1.4.13, 1.5.10, 1.6.1)