Linux Kernelの脆弱性(Moderate: CVE-2022-1729)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

05/24/2022にLinux Kernelの脆弱性(Moderate: CVE-2022-1729)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-1729

CVE-2022-1729: race condition in Linux perf subsystem leads to local privilege escalation

Red Hat: 7.0 Moderate

Red Hat: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-1729
    • ローカルの権限昇格の可能性
    • 5.4.193以上のLinux Kernelでは、perfサブシステムに競合が発生することがあり、これによりローカルユーザが権限昇格をできる可能性があります。

      主要なディストリビューションでは、perfを非特権ユーザに使用させないようになっているため、本脆弱性の影響を受ける可能性は少ないです。

    • 迂回方法
      
      $ sudo /sbin/sysctl -w "kernel/perf_event_paranoid=3"
      
      を実行することにより、非特権のユーザがperfサブシステムを使用できないようにすることが出来ます。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

BIND 9の脆弱性情報(High: CVE-2022-1183)と新バージョン(9.16.28, 9.18.3, 9.19.1 )

次へ

PostgreSQLの脆弱性情報(Important: CVE-2022-1552)と新バージョン(14.3, 13.7, 12.11, 11.16, 10.21)