kubernetesに複数の脆弱性(CVE-2017-1002101, CVE-2017-1002102) — | サイオスOSS | サイオステクノロジー

kubernetesに複数の脆弱性(CVE-2017-1002101, CVE-2017-1002102) — | サイオスOSS | サイオステクノロジー

現在位置: ホーム / セキュリティ ブログ / kubernetesに複数の脆弱性(CVE-2017-1002101, CVE-2017-1002102)
 

kubernetesに複数の脆弱性(CVE-2017-1002101, CVE-2017-1002102)

3/14/2018にkubernetesに複数の脆弱性情報(CVE-2017-1002101, CVE-2017-1002102)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。
 


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

3/14/2018にkubernetesに複数の脆弱性情報(CVE-2017-1002101, CVE-2017-1002102)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Important(CVE-2017-1002101)/Moderate(CVE-2017-1000122)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1002101
    • ホストのファイルシステムを含むボリュームへのアクセスの可能性

    • 重要度 - Important

    • 影響を受けるバージョン :

      • Kubernetes 1.3.x-1.6.x

      • Kubernetes 1.7.0-1.7.13

      • Kubernetes 1.8.0-1.8.8

      • Kubernetes 1.9.0-1.9.3

    • 特別に細工されたpod specと悪意のあるコンテナにより、podに記載された外部ボリュームの任意のファイルにread/writeのアクセスが可能になります。任意のボリュームタイプ、空のディレクトリに対して非特権のpodでアクセスが遂行されます。

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1002102
    • nodeが動作しているホストの任意のファイルの可能性

    • 重要度 - Moderate

    • 影響を受けるバージョン :

      • Kubernetes 1.3.x-1.6.x

      • Kubernetes 1.7.0-1.7.13

      • Kubernetes 1.8.0-1.8.8

      • Kubernetes 1.9.0-1.9.3

    • secret, configMap, downwardAPI, 或いはprojectedのボリュームを使うpodを悪意のあるコンテナから動作させることで、Kubeletにホストのファイルシステムの任意のディレクトリ又はファイルを削除されてしまう可能性が有ります。



対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

 
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン

----- EXTENDED BODY:

前へ

kernelの脆弱性( CVE-2017-7184 ) — | サイオスOSS | サイオステクノロジー

次へ

Tomcatの複数の脆弱性 ( CVE-2017-12617, CVE-2017-12615 , CVE-2017-12616 ) — | サイオスOSS | サイオステクノロジー