libgcryptの脆弱性情報(Moderate: CVE-2021-33560)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

06/02/2021に、libgcryptの脆弱性情報(Moderate: CVE-2021-33560)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



libgcryptの脆弱性情報(Critical: CVE-2021-3345)



Priority

CVE番号 影響するバージョ ン Priority CVSS Score / CVS S Vector
CVE-2021-33560 libgcrypt < 1.8.8, libgcrypt < 1.9.3

Red Hat: Moderate

Red Hat: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2021-33560
    • ヒープバッファーオーバーフローの可能性
    • 1.8.8, 1.9.3 より前のLibgcryptでは、サイドチャネル攻撃に対抗するためのmpi_powm()関数での指数ブラインドが不足していることと、ウィンドウサイズが適切に選択されていないために、ElGamal暗号の処理に問題を含んでいました。これは、例えばOpenPGPでのElGamal使用に影響があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内

CM

こちらで小学生の勉強支援サイトをオープンしました。算数のプリント(都度、自動生成)が無料でダウンロードできます。コンテンツは未だ少ないですが、徐々に増やしていきます。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

polkitの脆弱性(Important: CVE-2021-3560)

次へ

curlの複数の脆弱性情報(High: CVE-2021-22901, Medium: CVE-2021-22898, Low: CVE-2021-22897 )