libVNCの脆弱性情報(Critical: CVE-2018-6307, CVE-2018-15126, CVE-2018-15127 ,CVE-2018-20019 ,CVE-2018-20020 Moderate/Medium:CVE-2018-20021 ,CVE-2018-20022 ,CVE-2018-20023 ,CVE-2018-20024)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/19/2018にlibVNCの脆弱性情報(Critical: CVE-2018-6307, CVE-2018-15126, CVE-2018-15127 ,CVE-2018-20019 ,CVE-2018-20020 Moderate/Medium:CVE-2018-20021 ,CVE-2018-20022 ,CVE-2018-20023 ,CVE-2018-20024)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2018-6307

    Critical

    • Kaspersky Lab
      • CVSS v3 Base Score: 10.0
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-15126

    Critical

    • Kaspersky Lab
      • CVSS v3 Base Score: 10.0
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-15127

    Critical

    • Kaspersky Lab
      • CVSS v3 Base Score: 10.0
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-20019

    Critical

    • Kaspersky Lab
      • CVSS v3 Base Score: 10.0
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-20020

    Critical

    • Kaspersky Lab
      • CVSS v3 Base Score: 10.0
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-20021

    Medium/Moderate

    • Kaspersky Lab
      • CVSS v3 Base Score: 7.5
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-20022

    Medium/Moderate

    • Kaspersky Lab
      • CVSS v3 Base Score: 8.6
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2018-20023

    Medium/Moderate

    • Kaspersky Lab
      • CVSS v3 Base Score: 8.6
      • Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
    • SuSE
    • Red Hat Customer Potal
    • NVD
    • Red Hat Customer Potal
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6307
    • リモートユーザによる任意のコード実行の可能性
    • 重要度 - Critical
    • コミットca2a5ac02fbbadd0a21fabba779c1ea69173d10bより前のlibVNCには、ファイル転送extensionのサーバコード部分にヒープuse-after-freeの問題がありました。リモートの攻撃者はこれを利用して、リモートからコードを実行することが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15126
    • リモートユーザによる任意のコード実行の可能性
    • 重要度 - Critical
    • コミット73cb96fec028a576a5a24417b57723b55854ad7bより前のlibVNCには、ファイル転送extensionのサーバコード部分にヒープuse-after-freeの問題がありました。リモートの攻撃者はこれを利用して、リモートからコードを実行することが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15127
    • リモートユーザによる任意のコード実行の可能性
    • 重要度 - Critical
    • コミット502821828ed00b4a2c4bef90683d0fd88ce495deより前のlibVNCには、ファイル転送extensionのサーバコード部分にヒープ領域外書き込みの問題がありました。リモートの攻撃者はこれを利用して、リモートからコードを実行することが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20019
    • リモートユーザによる任意のコード実行の可能性
    • 重要度 - Critical
    • コミットa83439b9fbe0f03c48eb94ed05729cb016f8b72fより前のlibVNCには、ファイル転送extensionのクライアントコード部分にヒープ領域外書き込みの問題がありました。リモートの攻撃者はこれを利用して、リモートからコードを実行することが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20020
    • リモートユーザによる任意のコード実行の可能性
    • 重要度 - Critical
    • コミット7b1ef0ffc4815cab9a96c7278394152bdc89dc4dより前のlibVNCには、ファイル転送extensionのクライアントコード部分にヒープ領域外書き込みの問題がありました。リモートの攻撃者はこれを利用して、リモートからコードを実行することが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20021
    • リモートユーザによるDoSの可能性
    • 重要度 - Medium/Moderate
    • コミットc3115350eb8bb635d0fdb4dbbb0d0541f38ed19cより前のlibVNCには、VNCクライアントコード部分にCWE-835: 無限ループの問題が含まれていました。リモートの攻撃者はこれを利用して、CPUとRAMを消費させることによりDoSを引き起こすことが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20022
    • リモートユーザによるメモリ情報漏えいの可能性
    • 重要度 - Medium/Moderate
    • コミット2f5b2ad1c6c99b1ac6482c95844a84d66bb52838より前のlibVNCには、VNCクライアントコード部分にCWE-665: 不完全な初期化の問題が含まれていました。リモートの攻撃者はこれを利用して、スタックメモリを読むことが出来るため、情報の漏洩に繋がります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20023
    • リモートユーザによるメモリ情報漏えいの可能性
    • 重要度 - Medium/Moderate
    • コミット8b06f835e259652b0ff026898014fc7297ade858より前のlibVNCには、VNCリピータークライアントコード部分にCWE-665: 不完全な初期化の問題が含まれていました。リモートの攻撃者はこれを利用して、スタックメモリを読むことが出来るため、情報の漏洩に繋がります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20024
    • リモートユーザによるDoSの可能性
    • 重要度 - Medium/Moderate
    • コミット4a21bbd097ef7c44bb000c3bd0907f96a10e4ce7より前のlibVNCには、VNCクライアントコード部分にNULLポインタ被参照の問題が含まれていました。リモートの攻撃者はこれを利用して、DoSを引き起こすことが可能です。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セミナー情報

2019/01/09 18:30-20:30で、「OSSライセンスMeetup Vol.1」を行います。

今回は技術評論社刊「OSSライセンスの教科書」著者・上田さんを迎えて刊行に至った理由・本著に込めた思い・見どころなどを語っていただき、後半ではテクニカルライター可知豊さんと共に上田さんと本書についてのディスカッションを行います。

https://sios.connpass.com/event/104422/がプログラム内容と申し込みの詳細になります。奮ってご参加下さい。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

ka-omo@torna

前へ

BIND 9(Red Hat Enterprise Linux/CentOSパッケージ版)の脆弱性情報(Moderate: CVE-2018-5742)

次へ

GNU Tarの脆弱性情報(CVE-2018-20482)