nginxの脆弱性(Important: CVE-2021-23017)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

05/25/2021にnginxの脆弱性(Important: CVE-2021-23017)が公開されました。少し遅くなりましたが、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



[過去の関連リンク]


Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2021-23017 < 5.9

[nginx-announce] nginx security advisory (CVE-2021-23017)

Red Hat: 8.1 Important

Red Hat: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-23017
    • 特権昇格の可能性
    • nginxに脆弱性が見つかりました。DNSレスポンスを処理している際に off-by-one errorが発生し、ネットワーク上の攻撃者が、あろけーとされているヒープバッファーの境界外にドットキャラクタを書き込むことを許可します。これにより、nextヒープチャンクメタデータの最下位バイトを上書きすることで、特定の状況でリモートコード実行を許可してしまいます。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

CM

こちらで小学生の勉強支援サイトをオープンしました。算数のプリント(都度、自動生成)が無料でダウンロードできます。コンテンツは未だ少ないですが、徐々に増やしていきます。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(Moderate: CVE-2021-20292)

次へ

Apacheの脆弱性情報(Important: CVE-2021-31618 Moderate: CVE-2021-30641, CVE-2021-13938, Low: CVE-2021-26691 CVE-2021-26690 CVE-2020-35452 CVE-2020-13950 CVE-2019-17567 ) と修正バージョン(2.4.48)