OpenLDAPの脆弱性情報(CVE-2020-12243)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

04/30/2020にOpenLDAPの脆弱性情報(High: CVE-2020-12243)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



[過去の関連リンク(最新10件)]



Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2020-12243 < 2.4.50

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12243
    • ネストされたブール式によるDoS(デーモンクラッシュ)の可能性
    • 2.4.50より前のOpenLDAPでは、slapd中のfilter.cに問題があり、LDAPサーチでネストされたブール式をフィルタに用いるとDoS(デーモンクラッシュ)が発生します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生する場合には、peacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Squidの複数の脆弱性情報(CVE-2019-12519, CVE-2019-12521, CVE-2020-11945)と新バージョン(4.11/5.0.2)

次へ

Sambaの複数の脆弱性情報(Medium: CVE-2020-10700, High: CVE-2020-10704)と修正バージョン(4.12.2, 4.11.8, 4.10.15)