Perlの複数の脆弱性情報(Important: CVE-2018-18311 / Moderate: CVE-2018-18312 , CVE-2018-18314 , Low: CVE-2018-18313)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/30/2018にPerlの複数の脆弱性情報(Important: CVE-2018-18311 / Moderate: CVE-2018-18312 , CVE-2018-18314 , Low: CVE-2018-18313)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2018-18311

    Moderate

    • SuSE
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 8.1
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
    • NVD
  • CVE-2018-18312

    Moderate

    • SuSE
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 7
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
    • NVD
  • CVE-2018-18313

    Moderate

    • SuSE
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 6.5
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
    • NVD
  • CVE-2018-18314

    Moderate

    • SuSE
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 7
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18311
    • バッファオーバーフローの可能性
    • 重要度 - Important
    • 5.8.0から5.28までのPerlで脆弱性が見つかりました。util.c中のPerl_my_setenv()関数に整数オーバーフローの問題があり、バッファオーバーフローを引き起こします。
    • コンテナを用いていない場合には影響度はModerateですが、信頼できないコンテナをOpenShift等で用いている場合には、影響度はImportantになります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18312
    • ヒープベースバッファーオーバーフローの可能性
    • 重要度 - Moderate
    • 5.18から5.26までのPerlに問題があり、ヒープベースバッファーオーバーフローとreg_nodeの超過を引き起こします。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18313
    • ヒープベースバッファーオーバーフローによる情報漏えいの可能性
    • 重要度 - Moderate
    • 5.22から5.26までのPerlに問題があり、regcomp.c中でヒープバッファーオーバーフローを利用して情報を読み取られる可能性があります。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18314
    • ヒープベースバッファーオーバーフローの可能性
    • 重要度 - Moderate
    • 5.18から5.26までのPerlに問題があり、ヒープベースバッファーオーバーフローを引き起こします。


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

セキュリティ系連載案内


セミナー情報 2

2019/01/09 18:30-20:30で、「OSSライセンスMeetup Vol.1」を行います。

今回は技術評論社刊「OSSライセンスの教科書」著者・上田さんを迎えて刊行に至った理由・本著に込めた思い・見どころなどを語っていただき、後半ではテクニカルライター可知豊さんと共に上田さんと本書についてのディスカッションを行います。

https://sios.connpass.com/event/104422/がプログラム内容と申し込みの詳細になります。奮ってご参加下さい。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Keycloakの脆弱性情報(Important: CVE-2018-14637)

次へ

BINDに関してのOperational Notification (DNSSEC鍵の削除による壊れたNSEC / NSEC3チェインと不要なRRSIGの生成)