PHPの脆弱性情報(CVE-2018-12882)




6/27/2018にphpの脆弱性情報(CVE-2018-12882)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

6/27/2018にphpの脆弱性情報(CVE-2018-12882)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12882
    • スタックベースのバッファーアンダーリードの可能性

    • 重要度 - Important

    • 7.2.7以前のPHP7.2.x系では、ext/exif/exif.c中のexif_read_from_impl()関数で、closingに対する応答が無い場合にストリームをcloseするために、攻撃者がuse-after-freeを引き起こす事ができる部分がexif_read_from_fileにあることがわかりました。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteやKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

https://bugs.php.net/bug.php?id=76409

セキュリティ系連載案内


セミナー情報

2018年07月13日 (金) 19:00から、「OSSセキュリティ技術の会 第三回勉強会 (副題:"Keycloak"で、"認証王"に!!!おれはなるっ!!!!)」 と題しまして、OSS認証基盤のKeycloakに特化した話をさせて頂きます。

https://secureoss-sig.connpass.com/event/90917/がプログラム内容と申し込みの詳細になりますので、是非お申し込み下さい。

前へ

Linux Kernelの脆弱性情報(CVE-2018-12714 )

次へ

rubygem-rubyzipの脆弱性(CVE-2018-1000544)