PHPの脆弱性情報(Important: CVE-2018-19518)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/25/2018にPHPの脆弱性情報(Important: CVE-2018-19518)が公開されています。すでにexploitも出回っており、この脆弱性を利用したインシデントも発生しているようですので、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2018-19518

    Important

    • SuSE
      • CVSS v3 Base Score: 5.3
      • Vector: AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 8.1
      • Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19518
    • リモートの攻撃者によるOSコマンド実行の可能性
    • 重要度 - Important
    • PHPのimap_open()で使われるIMAP Toolkit 2007fでは、rshコマンドを引数インジェクションの防御無しに実行する(これはc-client/imap4r1.cのimap_rimap()関数とosdep/unix/tcp_unix.cのtcp_aopen()関数で行われます)ため、IMAPサーバ名が信頼できない入力の場合(すなわち、Webアプリケーションのユーザによって入力された場合)、rshが異なる引数を持つプログラムに置き換えられた場合、リモートの攻撃者が任意のOSコマンドを実行することが出来ます。例えば、(DebianとUbuntuのシステムにみられるように)rshがsshへのリンクの場合、攻撃はIMAPサーバ名が"-oProxyCommand"引数を含んでいる場合に成功します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性情報(Moderate: CVE-2018-14646, CVE-2018-16862)

次へ

PowerDNSの複数の脆弱性情報(Low:CVE-2018-14663 , Medium:CVE-2018-16855)