PHPの脆弱性情報(CVE-2020-7067)と新バージョン(7.2.30, 7.3.17, 7.4.5)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

04/16/2020にPHPの脆弱性情報(CVE-2020-7067)と新バージョン(7.2.30, 7.3.17, 7.4.5)が公開されていました。遅くなりましたが、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




CVSS/一次情報源

CVE番号 影響するバージョン リファレンス Priority CVSS
CVE-2020-7067 7.2.30より前の7.2.x系, 7.3.17より前の7.3.x系, 7.4.5より前の7.4.x系

OOB Read in urldecode()

Vendor: 7.5 HIGH

Vendor: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-7067
    • 境界外読み込みの可能性
    • PHPがEDBCDICサポート(一般的ではありません)でコンパイルされている場合、配列中に符号付き番号が誤って使用されるため、urldecode()関数が過去にアロケートされていたメモリにアクセスできる問題があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの複数の脆弱性情報(CVE-2020-12464, CVE-2020-12465)

次へ

Linux Kernelの複数の脆弱性情報(CVE-2020-12652, CVE-2020-12653, CVE-2020-12654, CVE-2020-12655, CVE-2020-12656, CVE-2020-12657, CVE-2020-12659)