phpMyAdminの複数の深刻な脆弱性情報(Severe(重大): CVE-2019-12616, Serious: CVE-2019-11768)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

06/05/2019にphpMyAdminの複数の深刻な脆弱性情報(Severe(重大): CVE-2019-12616, Serious: CVE-2019-11768)が公開されています。重大な脆弱性も含まれていますので、今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。





Priority

  • CVE-2019-12616

    Severe(重大)

    • SuSE
    • Red Hat Customer Potal
    • NVD
  • CVE-2019-11768

    Serious

    • SuSE
    • Red Hat Customer Potal
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11768
    • Designer機能でのSQLインジェクションの可能性
    • 重要度 - Serious(深刻)
    • CWE ID: CWE-661
    • 影響範囲:4.8.5以前のバージョン
    • phpMyAdminにSQLインジェクションの脆弱性が見つかりました。特別に細工されたデータベース名を用いて、攻撃者はDesigner機能を通してSQLインジェクションを仕掛けることが可能です。
  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12616
    • loginフォームのCSRF脆弱性
    • 重要度 - Severe
    • 影響範囲:4.9.0より前のバージョン
    • 攻撃者がphpMyAdminユーザに対してCSRF攻撃を仕掛けることが出来るトリガーとなる脆弱性が見つかりました。攻撃者は被害者のphpMyAdminデータベースを示すような壊れたタグを介してユーザを騙し、被害者を通じてペイロード(特定のINSERTやDELETEステートメント)を発行することが出来る可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


セミナー情報 1

2019/06/07 19:00に、「OSSセキュリティ技術の会 第五回勉強会 (副題:KeycloakとWebAuthnのツインシュートの巻)」と題しまして、勉強会を開催することになりました。 コミュニティ開発に携わる人が最前線を語ります。開発コミュニティへの要望welcomeです。

プログラム内容と申し込みの詳細につきましては、 下記の通りとなります。奮ってご参加下さい。

https://secureoss-sig.connpass.com/event/130011/


セミナー情報2

2019/07/31 10:00-17:00で開催される、一般社団法人 日本情報システム・ユーザ協会(JUAS)様による有料ハンズオンセミナー「ハンズオンで学ぶ!クラウド時代の運用管理とセキュリティ対策 」にて当ブログの筆者「面 和毅」が講師を努めます。

本セミナーでは、大手ベンダーや外資系企業、ユーザー企業などでセキュリティの専門家として20年以上の経験を持ち、現在、セキュリティエバンジェリストとして活躍する講師が実体験を交えながら、クラウド上のサーバーを安価に守る方法を、演習をまじえ、具体的にお伝えします。

https://juasseminar.jp/seminars/view/4119290にて申し込みを行っております。奮ってご参加ください。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性情報(Important: CVE-2019-3846)

次へ

eximの深刻な脆弱性情報(Critical: CVE-2019-10149)