phpMyadminの脆弱性情報(Serious(深刻): CVE-2019-18622)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

11/22/2019にphpMyadminの脆弱性情報(Serious(深刻): CVE-2019-18622)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



一次情報源

PMASA-2019-5

Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2019-18622 <4.7.7 <= phpMyadmin < 4.9.2

Vendor: Serious(深刻)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18622
    • デザイナ機能でのSQLインジェクションの可能性
    • 4.9.2より前のphpMyadminには、デザイナ機能に特別に細工されたデータベース名を用いることによりSQLインジェクション攻撃を可能にする脆弱性があります。
    • 解決方法:4.9.2以上のバージョンに更新して下さい。詳しくは各ディストリビューションの指示に従って下さい。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

[参考]

PMASA-2019-5

セキュリティ系連載案内

セミナー情報1

OSSセキュリティ技術の会では、2019/12/13(金) 19:00-21:00に「OSSセキュリティ技術の会 第七回勉強会(副題:君がッ泣くまで入力をやめないッ! ~Linuxカーネルの高度な試験自動化技術と バグハンティングの巻~)」と題して、「syzkaller/syzbot」をテーマに勉強会を開催することになりました。

Linux カーネルのソースコードカバレッジを活用した高度な試験自動化技術について話していただきます。

プログラム内容と申し込みの詳細についてはこちら(connpass)を御確認下さい。

セミナー情報2

12/23(月) 19:00から21:00で、恵比寿のRed Hat様(会場)「RHEL好きの集い」コミュニティによるイベント「RHEL好きの集い Vol.2.1 」を開催致します。

今回は"〜RHEL8のライブカーネルパッチとUBIを深堀り〜"と題しまして、RHEL8.1から正式サポートになりましたkpatchと、UBIを深堀するイベントとなります。

プログラム内容と申し込みの詳細につきましては、こちら(connpass)を御確認下さい。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

BIND 9 の脆弱性情報(Medium: CVE-2019-6477)

次へ

Linux Kernelの脆弱性情報(CVE-2019-18675)