phpMyadminの脆弱性情報(Serious(深刻): CVE-2020-5504)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

01/05/2019にphpMyadminの脆弱性情報(Serious(深刻): CVE-2020-5504)が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



一次情報源

PMASA-2020-1

Priority

CVE番号 影響するバージョン Priority CVSS Score / CVSS Vector
CVE-2020-5504 4.x: phpMyAdmin < 4.9.4, 5.x: phpMyAdmin <= 5.0.0

Vendor: Serious(深刻)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5504
    • ユーザアカウントページでのSQLインジェクション
    • ユーザアカウントページにSQLインジェクションの脆弱性が見つかりました。悪意のあるユーザはページのクエリを作成する際に、自分のユーザ名の代わりに細工したSQLをインジェクション出来ます。攻撃者には、サーバにアクセスするための有効なMySQLアカウントが必要になります。
    • 解決方法:4.9.4/5.0.1以上のバージョンに更新して下さい。詳しくは各ディストリビューションの指示に従って下さい。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

[参考]

PMASA-2020-1

セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

cpioの脆弱性情報(Moderate: CVE-2019-14866)

次へ

Linux Kernelの脆弱性情報(CVE-2019-19332)