PhpMyAdminの脆弱性(Moderate: CVE-2022-0813)と新バージョン(4.9.10, 5.1.3)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/09/2022にPhpMyAdminの脆弱性(Moderate: CVE-2022-0813)と新バージョン(4.9.10, 5.1.3)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

CVE番号 影響するバージョン 一次情報源 Priority CVSS Score / CVSS Vector
CVE-2022-0813 PhpMyAdmin <= 5.1.1

PhpMyAdmin exposure of sensitive information

INCIBE-CERT: 5.3 Medium

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0813
    • 重要な情報取得の可能性
    • 5.1.1以前のPhpMyAdminでは攻撃者が不正なリクエストを作成することで重要な情報を取得できる可能性があります。これはlangパラメータ、pma_paramaeter、cookieセクションに影響します。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

Linux Kernelの脆弱性(Important: CVE-2022-0847 (Dirty Pipe))とPoC(RHEL9beta+SELinux)

次へ

Apache HTTP Serverの脆弱性情報(Important: CVE-2022-22720, CVE-2022-23943, Moderate: CVE-2022-22719, Low: CVE-2022-22721)と修正版(2.4.53)リリース