PostgreSQLの脆弱性(CVE-2018-1058) — | サイオスOSS | サイオステクノロジー

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/01/2018にPostgreSQLの脆弱性情報(CVE-2018-1058)とアップデートが公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate

CVSS Severity (version 3.0):

  • CVSS v3 Base Score: 8.8 Medium

  • Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

影響を受けるバージョン

9.3, 9.4, 9.5, 9.6, 10

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1058
    • pg_dumpとその他のアプリケーション中の制御できない検索パス要素

    • 重要度 - Moderate

    • 他のユーザのクエリを変更することが出来る欠陥がPostgreSQLに見つかりました。 ユーザーアカウントを持つ攻撃者は、この欠陥を利用してデータベース内のスーパーユーザーの権限でコードを実行できます。

      詳しい情報は、特設サイトA Guide to CVE-2018-1058: Protect Your Search Pathを御確認ください。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、関連するサービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(CVE-2018-1000199) — | サイオスOSS | サイオステクノロジー

次へ

shadow-utilsの脆弱性(CVE-2017-12424) — | サイオスOSS | サイオステクノロジー