PostgreSQLの重要な脆弱性(CVE-2018-10915, CVE-2018-10925)


近日中にこちらのコンテンツの内容はhttps://security.sios.comに移行されます。



08/10/2018にPostgreSQLの脆弱性情報(CVE-2018-10915, CVE-2018-10925)とアップデートが公開されました。PriorityとしてはLowですが、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

08/10/2018にPostgreSQLの脆弱性情報(CVE-2018-10915, CVE-2018-10925)とアップデートが公開されました。PriorityとしてはLowですが、今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority/影響を受けるバージョン

Important

  • CVE-2018-10915 (client)

    影響を受けるバージョン: 9.3, 9.4, 9.5, 9.6, 10

    CVSS Severity (version 3.0):

    • CVSS v3 Base Score: 8.5
    • Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
  • CVE-2018-10925 (core)

    影響を受けるバージョン: 9.5, 9.6, 10

    CVSS Severity (version 3.0):

    • CVSS v3 Base Score: 7.1
    • Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10915
    • 特定のホスト接続パラメータによるクライアント側のセキュリティ防御の無効化
    • 重要度 - Important
    • libpq(他の接続ライブラリにも使用されている、PostgreSQLのクライアント接続API)で、再接続をする際に全ての接続状態変数をリセットしていなかったという問題が見つかりました。特に、パスワードが接続に必要かどうかを決定するような状態変数もリセットされていなかったため、dblinkpostgres_fdwのようなlibpqを使用している機能を用いているユーザは、攻撃者からクライアント-サーバ間の接続をバイパスされてしまう可能性があります。

      dblink又はpostgres_fdwエクステンションがインストールされているかどうかは、PostgreSQLのシェルで

      \dx dblink|postgres_fdw

      を実行することで確認できます。

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10925
    • INSERT ... ON CONFLICT DO UPDATEでのメモリ開示と認証の消失
    • 重要度 - Important
    • CREATE_TABLEを実行できる攻撃者はupsert (INSERT ... ON CONFLICT DO UPDATE)を実行することによりサーバメモリの任意のバイトを読むことが出来ます。デフォルトでは、全てのユーザがこれを実行することが出来ます。INSERT特権とUPDATE特権を少なくとも1つのカラムに対して持っているユーザは、viewとupsertクエリを使って他のカラムをupdateすることが出来ます。



対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。< /p>

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を参考にして下さい。

また、サービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24, and 11 Beta 3 Released!(https://www.postgresql.org/about/news/1878/)

セキュリティ系連載案内


セミナー情報 1

2018年10月22日から10月25日のCSS(Computer Security Symposium)2018で、「OSSセキュリティ技術ワークショップ(OWS) 2018特別セッション」 と題しまして、OSSセキュリティ技術の会後援で特別セッションを開催します。

https://www.iwsec.org/ows/2018/index.htmlにプログラム内容と一般論文申し込みの詳細を載せていきますので、是非御確認下さい(ページは更新中です)。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(CVE-2018-5953, CVE-2018-5995 )

次へ

cups関連での特権昇格等の脆弱性(CVE-2017-15400, CVE-2018-4180, CVE-2018-4181, CVE-2018-6553 )